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SOFTWARE DI PRODUTTIVITA’ 
PERSONALE



  

Definizione

La locuzione software di produttività personale (genericamente 
anche suite per ufficio, in inglese office automation), in informatica, 
indica un insieme di applicazioni che permettono all'utente di un 
computer di creare dei contenuti quali documenti di testo, grafici o 
presentazioni, tipicamente ad uso personale o nel lavoro d'ufficio. Si 
tratta di strumenti comunemente utilizzati nell'ambito 
dell'informatica di base.(Fonte Wikipedia)

• Mondo OpenSource , software sotto varie licenze di cui e’ 
disponibile il codice sorgente. Nel 1983 Richard Stallman, uno 
degli autori originali di Emacs e membro di lunga data della 
comunità hacker presso il laboratorio di intelligenza artificiale del 
MIT, fondò il progetto GNU 

•



  

Lista

● OpenOffice: suite derivata da StaOffice, multi piattaforma con 
licenza Apache 2 (software libero)

● LibreOffice fork di OpenOffice , anche questo software libero 
multi piattaforma

● Altri esempi di suite office libere, WPS Office, NeoOffice, Go-oo, 
Koffice, GNOME Office

● Microsoft Office, prodotto commerciale Microsoft

● iWork, prodotto commerciale Apple

● Google Docs, Sheets, Slides programmi basati sul Web (web-
based) , gratutit, sono parte del servizio Google Drive

•



  

FOGLIO ELETTRONICO



  

Fogli di calcolo

● Di base una tabelle (matrice di dati righe e colonne) 

● In ogni cella e’ possibile inserire dati, numeri e formule che 
possono usare come dati di input altre celle

● Le formule possono far parte di librerie note oppure esser 
definite dall’utente

● Si possono poi inserire grafici ed altri contenuti 

● Le colonne sono indicate da lettere 

● Le righe da numeri 

•



  

Foglio elettronico

VisiCalc
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USIAMO I SETTINGS US



  

Fogli di calcolo

● Andate su impostazioni



  

Fogli di calcolo

● Modifica Lingua
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PRIMI ESEMPI PRATICI



  

Fogli di calcolo

● Scaricate il file data.txt 

● Dopo avere creato uno spreadsheet vuoto File -> import



  

Fogli di calcolo

● A questo punto selezioniamo la colonna e poi Insert -> 
Chart



  

USO DELLE FUNZIONI 
PREDEFINITE



  

Fogli di calcolo

● I fogli di calcolo mettono a disposizione numerose funzioni 
predefinite come ad empio il calcolo del valore minimo o 
massimo o valore medio

● Per usare queste funzioni predefinite basta in una data 
cella usare il carattere = e poi ... 



  

Fogli di calcolo



  

FUNZIONI PREDEFINITE 
CASO D’USO



  

Fogli di Calcolo

● Adesso iniziamo a lavorare con i dati. Ad esempio scopo 
finale quello di trovare alcune “misure di posizione” e 
plottare una distribuzione normale sopra l’istogramma 



  

Fogli di Calcolo

● Crea un intervallo denominato “valori”  partendp dai punti 
importanti questo ci semplifichera’ le operazioni 
successive.

● Selezioniamo la colonna A, quindi fai clic sul menu Data -> 
Named ranges 



  

Fogli di Calcolo

● Adesso possiamo ad esempio, come prima, calcolare 
alcune statistiche:

– =MODE(valori) quel valore che se esiste si presenta 
con maggiore frequenza

– =MEDIAN(valori) il valore che occupa il posto centrale 
in una serie di dati disposti in ordine crescente o 
decrescente



  

Fogli di Calcolo

● Adesso possiamo ad esempio, come prima, calcolare 
alcune statistiche:

– =STDEVP(valori)



  

Fogli di Calcolo

● Creiamo i bin del nostro istogramma. Nella colonna E mettiamo 
nella prima cella (E1) l’header “BINS”. Poi in E2 scriviamo 45 
(minimo calcolato 50) ed in E3 =E2+5 (operazioni in cui sono 
coinvolte altre celle) 

● A questo punto basta chiedere di duplicare l’equazione 
semplicemente trascinando: 

fino ad E16 (valore 115)  



  

Fogli di Calcolo

Ed ecco i bins:



  

Fogli di Calcolo

● A questo punto sui bins calcoliamo i valori della 
distribuzione normale con media e deviazione standard 
data dai calcoli precedenti:

● =NORMDIST(E2,$C$3,$C$7,FALSE) in F2 e poi al solito 
trasciniamo per duplicare il calcolo sugli altri valori (nota 
parametro 2 e 3 sono costanti evito lo scorrimento 
quando trascino e il quarto e’ per chiedere o meno la 
cumulata)



  

Fogli di Calcolo

● Vediamo adesso il grafico della distribuzione normale : 
Insert -> Chart e poi come chart type Line chart 

● Selezioniamo poi i dati per X ed Y e su Customize -> 
Chart style -> Smooth



  

Fogli di Calcolo

● Il risultato dovrebbe essere 



  

Fogli di Calcolo

● Adesso calcoliamo le frequenze nei vari bins, creiamo un 
secondo Named ranges selezionando i bin (E2 fino E16) e 
poi nuovamente Data -> Named ranges chiniamolo bins 



  

Fogli di Calcolo

● =FREQUENCY(valori,bins) in G2  che calcola la 
frequenza di distribuzione di una colonna in una data 
classe

Il primo dato rappresenta 
i valori inferiori a  45 e 
l’ultimo e’ il numero totale
 di valori valori  superiori a 115



  

Fogli di Calcolo

● Per poterli rappresentare in un grafico innanzi tutto 
dobbiamo riscalare i valori dell’istogramma dividendo ogni 
valore per la somma

● In I2 mettiamo =SUM(G2:G17)=SUM(G2:G17) e poi calcoliamo la  e poi calcoliamo la 
frequenza in colonna H usandofrequenza in colonna H usando =G2/(5*$I$2) =G2/(5*$I$2) in H2 ed in  in H2 ed in 
seguito solito trascinamento (seguito solito trascinamento (moltiplico per 5 che e’ la moltiplico per 5 che e’ la 
larghezza di ogni binlarghezza di ogni bin) ) 



  

Fogli di Calcolo



  

Fogli di Calcolo

● Adesso possiamo rappresentare tutti i dati assieme  
assieme selezionando le colonne di interesse (usando 
Ctrl) Insert -> Chart



  

Fogli di Calcolo

● Ci interessa Combo chart 

la prima serie dovra’ essere 

l’istogramma e la seconda 

I punti della distribuzione

normale

● Al solito poi Customize ->

Chart style e Smooth



  

Fogli di Calcolo



  

TEST1



  

Fogli di Calcolo

● Adesso provate a fare la stessa cosa usando 
generate.py oppure direttamente testvalue.csv

Per i bin in questo caso usiamo 0,1 o 0,3 o 0,5 ad 
esempio



  

Introduzione all'Informatica

Loriano Storchi

loriano@storchi.org

http:://www.storchi.org/

mailto:loriano@storchi.org


  

FORMATTAZIONE



  

Fogli di calcolo

● Iniziamo importando i soliti dati data.txt

● Successivamente calcoliamo la mediana (quindi usiamo la 
funzione MEDIAN )



  

Fogli di calcolo

● A questo punto coloriamo diversamente tutti i valori 
inferiori alla mediana o superiori alla mediana 

● Dopo aver selezionato la colonna Format -> Conditional 
formatting 



  

Fogli di calcolo

● Fatto possiamo aggiungere una seconda condizione 
semplicemente premendo Done e poi Add onother rule 



  

Fogli di calcolo

 



  

ALTRO ESEMPIO DI 
FORMATTAZIONE



  

Fogli di calcolo

● Aggiungiamo UN SECONDO Sheet 

● In A2 inseriamo una data qualsiasi ad esempio 02/03/2019

● E poi trasciniamo  



  

Fogli di calcolo

● In B2 usiamo la funzione =WEEKDAY(A2)

● E poi trasciniamo  



  

Fogli di calcolo

● Selezioniamo tutte le righe dalla 2 alla ... (26 nel mio caso) 
usando la barra dei numeri di riga e poi Format -> 
Conditional formatting 



  

Fogli di calcolo

● Coloriamo il colore di una riga intera basandosi sul valore 
di una colonna specifica. Dopo aver selezionato tutto il 
foglio di cacolo

● Dobbiamo scegliere Custom formula is e poi 
=$B$1:$B$26=6



  

Fogli di calcolo



  

TEST2



  

Fogli di calcolo

● Generiamo una colonna con le date, partendo dalla data di 
una settimana fa, e coloriamo di vede la casella 
corrispondente alla data odierna 
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PIVOT TABLE



  

Fogli di calcolo

● Pivot Table: Una tabella pivot è uno strumento per 
preparare un sunto dei dati di una tabella, usando 
operazioni di media, sorting e somma (aggragazione dei 
dati)

● Si applicano a dati “ben formattati” ogni colonna e’ una 
variabile ed ogni riga e’ una singola osservazione



  

Fogli di calcolo

● Pivot Table: Una tabella di statistiche che riepiloga i dati di 
una tabella più ampia (ad esempio da un database, un 
foglio di calcolo o ....). Questo riepilogo includerebbe 
somme, medie o altre statistiche, che la tabella pivot 
raggruppa in modo significativo.



  

Fogli di calcolo

● Immaginiamo una compagnia che vende dipinti, di seguito 
di dati di vendita in relazione al venditore ed al tipo (colore) 
oltre che l’anno di vendita



  

Fogli di calcolo

● Vogliamo organizzare i dati di modo ad esempio da trarre 
conclusioni sulle vendite, ad esempio quanti quadri venduti 
per ogni anni da quale venditore 



  

Fogli di calcolo

● Oppure quanti quadri venduti e da chi per ogni tipo 
(colore)



  

Fogli di calcolo

● Usiamo data.csv 

 



  

Fogli di calcolo

● Quanto e’ stato fatturato per ogni progetto ? 

● Selezioniamo i dati e poi Data → Pivot Table

● Poi a Rows metti Add e seleziona Project type

● Invece in Values Add e Amount Billed e quindi SUM

● Oltre la somma possiamo anche aggiungere ad esempio media e 
minimo e massimo e deviazione standard per ognuno basta in 
Values premere ADD selezionare Amount Billed e ... 

 



  

Fogli di calcolo

● Il risultato finale sara’

 



  

Fogli di calcolo

● Per ogni cliente fra tutti i progetti quanto abbiamo fatturato 
nel 2017 ?

● Righe e colonne ti aiutano a costruire il set di dati 
bidimensionale su cui puoi calcolare i valori (la terza 
dimensione). In questo caso, i nostri dati di base sono Nome 
cliente (riga) e Tipo progetto (colonna).

● Il valore che vogliamo ottenere nelle celle in cui si incontrano il 
nome del cliente e il tipo di progetto è l'importo totale fatturato.

● Come mostriamo i dati solo dal 2017? È qui che entra in gioco il 
filtro. Il filtro ti consente di analizzare solo un sottoinsieme 
specifico di dati.



  

Fogli di calcolo

● In Rows ADD Client Name: Ha preso la parte selezionata dei 
dati originali, rimosso eventuali duplicati e ora ti mostra i dati 
in un rapporto. La colonna ora ha un elenco univoco di client 
in ordine alfabetico (A-Z).

● Columns ADD Project Type

● Values ADD Amount Billed (Summirized by SUM) : anche il 
"Totale generale" viene aggiunto e calcolato 
automaticamente. Ciò ci consente di vedere l'importo totale 
che abbiamo fatturato a ciascun cliente e l'importo totale che 
abbiamo fatturato per un determinato tipo di progetto tra tutti i 
clienti.



  

Fogli di calcolo

● Il risultati finale sarà



  

Fogli di calcolo

● Questo ci permette facilmente di vedere quanto ogni 
cliente ha pagato e quanto ogni progetto ha guadagnato, 
in una sola tabella

● Per rispondere pero’ alla nostra domanda iniziale 
dobbiamo ancora aggiungere un filtro:

– Filters ADD e quindi selezionare Year , a questo punto 
in Status ci darà la possibilità di selezionare 2017 e/o 
2018



  

Fogli di calcolo

● Il risultato finale sarà



  

TEST3



  

Fogli di calcolo

● Fare una Pivot table in cui calcolate per ogni progetto il 
valore di incasso minimo, massimo, medio e totale per il 
solo anno 2018 assieme alle ore spese



  

VLOOKUP



  

Fogli di Calcolo

● Quando si lavora con dati intercorrelati, una delle sfide più 
comuni è trovare informazioni su più fogli

● VLOOKUP cerca e recupera i dati corrispondenti da 
un'altra tabella sullo stesso foglio o da un altro foglio



  

Fogli di Calcolo

● VLOOKUP(search_key, range, index, [is_sorted])

● searcch_key: è il valore da cercare (valore di ricerca o identificativo 
univoco). Ad esempio, è possibile cercare la parola "mela", il numero 
10 o il valore nella cella A2.

● range: due o più colonne di dati per la ricerca. La funzione cerca 
sempre nella prima colonna dell'intervallo. 

● index: il numero di colonna nell'intervallo da cui deve essere 
restituito un valore corrispondente (le colonne sono numerate da 1).

● is_sorted: Indica se la colonna da cercare (la prima colonna 
dell'intervallo specificato) è ordinata. FALSE è raccomandato nella 
maggior parte dei casi. Se FALSE cerca il primo match esatto



  

Fogli di Calcolo

● Usiamo i dati contenuti in vlook.csv



  

Fogli di Calcolo

● In D2 scriviamo:

– =VLOOKUP(A2, $F$2:$G$7, 2, FALSE)

Quindi cerca la chiave presente in A2 nelle tabella  
identificata dall’intervallo F2:G7 quindi cerchera’ nella 
prima colonna ma ritornera’ il valore della colonna 
numero 2. Dati non ordinati.

– Notate che abbiamo usato $F$2:$G$7 per poter poi 
trascinare nel colito modo e copiare la stessa funzione 
su tutte le righe della colonna D



  

Fogli di Calcolo

● Risultato finale:



  

TEST4



  

Fogli di Calcolo

● Utilizzando i dati di test4.csv e vlookup fare un foglio di 
calcolo in cui si possa recuperare il voto di matematica 
dato il nome di uno studente inserito in una cella



  

TEST5



  

Fogli di Calcolo

● La funzione MATCH 

– lookup_value - Il valore per per cui stai cercando una 
corrispondenza nel lookup_array.

– lookup_array - L'intervallo di celle in cui si sta cercando 
il lookup_value.

– [match_type] - (Facoltativo) Specifica come  dovrebbe 
cercare un valore corrispondente. 0 prima 
corrispondenza esatta



  

Fogli di Calcolo

● Ad esempio in un nuovo Sheet scriviamo in colonna i 
valori A, B, ...



  

Fogli di Calcolo

● Usando gli stessi dati di TEST4 usare una combinazione 
di VLOOKUP e MATCH per ritornare il valore del voto  
dato il nome dello studente e della materia
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MACRO



  

Fogli di calcolo

● Macro: in pratica una funzione definita dall’utente che 
riceve come parametri i valori contenuti nelle celle

● Google Sheets usa JavaScript come linguaggio per la 
definizione delle macro 

● Possiamo usare una macro per ad esempio automatizzare 
una serie di operazioni



  

Fogli di calcolo

● Importiamo il file world-population-1750-2015-and-un-
projection-until-2100.csv

● E poi Tools → Macros → Record Macros 



  

Fogli di calcolo

● Adesso facciamo una serie di operazioni:

– Selezionare prima riga e  Format → Text Wrapping → 
Wrap

– Selezioniamo da A1 ad E1 e coloriamo lo sfondo di 
rosso

– Poi selezioniamo le colonne dalla A alla E e poi Format 
→ Alternating Colors

– Salviamo adesso la macro semplicemente premendo in 
save chiamiamola formatter



  

Fogli di calcolo

● Adesso aggiungiamo una nuova sheet e importiamo il file 
world-population-subset.csv 



  

Fogli di calcolo

● Adesso proviamo ad eseguire la nostra Macro 
semplicemente Tools → Macros → formatter



  

Fogli di calcolo

● Adesso  Tools → Script editor



  

SCRIVERE UNA FUNZIONE 
CUSTOM



  

Fogli di calcolo

● Creiamo un nuovo Sheet

● Ed inseriamo alcuni valori 



  

Fogli di calcolo

● Tools → Scripts editor

● Poi File → New -> Script File

 



  

Fogli di calcolo

● Usiamo la nostra funzione su i dati 

– In D2 scriviamo =ADOUBLE(A1)
– In D3 =ADOUBLE(A2:B3)

 



  

TEST5



  

Fogli di calcolo

● Scriviamo una macro che semplicemente cambi il segno ai 
numeri

 



  

TEST6



  

Fogli di calcolo

● Con Math.abs() potete ottenere il valore assoluto:

b = Math.abs(input);

● b%2 ritorna il resto della divisione per 2 

● Scrivere una funzione che inverta il segno dei soli numeri 
pari 

 



  

OLTRE I FOGLI DI CALCOLO 
ESEMPI PRATICI



  

Oltre un paio di esempi in python

● Media e deviazione standard txt file o pandas:

Repo git: https://github.com/lstorchi/teaching

dir basictests

https://github.com/lstorchi/teaching


  

Oltre un paio di esempi in python

●



  

Oltre un paio di esempi in python

●
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STUDIO DI FUNZIONI



  

Fogli di calcolo

● Useremo il foglio di calcolo per fare una rappresentazione 
di funzione ed impostare un semplice studio di funzioni 
con calcolo numerico della derivata e dell’integrale



  

RICHIAMI DI BASE



  

Studio di funzioni

● Definizione di funzione: Una funzione e’ una legge di 
corrispondenza che collega fra di loro gli elementi di due 
insiemi:

f : A→ B 

e’ una funzione se e solo se ad ogni elemento di A e’ 
associato un solo elemento di B 



  

Studio di funzioni



  

Studio di funzioni

● Chiamiamo l'insieme di partenza A Dominio e B 
Codominio. Il sottoinsieme degli elementi di B che 
vengono raggiunti mediante l’applicazione della funzione f 
si chiama invece immagine della funzione e puo’ 
coincidere con il codominio B

● Di nostro specifico interesse sono le funzioni reali a 
variabile reale



  

Studio di funzioni

Posso definire anche 
Funzioni in Rn



  

Studio di funzioni

● Funzione suriettiva : ogni elemento del secondo insieme 
(B) e’ raggiunta da almeno “una freccia” che parte dal 
primo insieme (A)



  

Studio di funzioni

● Funzione iniettiva : se elementi distinti del dominio hanno 
immagini distinte . Quindi ogni elemento dell’immagine in 
B non ammette piu’ di una preimmagine in A



  

Studio di funzioni

● Funzione biettiva : e’ una funzione che e’ sia suriettiva 
che iniettiva



  

Studio di funzioni

● Una funzione biettiva e’  invertibile  quindi e’ possibile 
determinare una legge che “collega” gli elementi 
dell’immagine agli elementi di A 



  

DOMINIO



  

Studio di funzioni

● Il dominio di una funzione reale, detto anche insieme di 
esistenza, e’ il sottinsieme di R in cui la funzione è definita 

● Per determinare il dominio basta individuare gli intervallio i 
punti in cui la funzione non e’ definita

● Rapporti → il dominio deve essere diverso da zero, ad 
esempio y = 1/x 



  

Studio di funzioni

● Logaritmi: l’esponente x da dare alla base a per 
ottenere l’argomento b



  

Studio di funzioni

● Esponente richiami



  

Studio di funzioni

● Logaritmi → l’argomento deve essere > 0 (la base deve 
essere maggiore di zero e diversa da 1)



  

Studio di funzioni

● Logaritmi → regola del cambio di base



  

Studio di funzioni

● Logaritmi → regola del cambio di base



  

Studio di funzioni

● radici →radici con indice pari il radicando deve essere 
maggiore o uguale a zero



  

Studio di funzioni

● radici →radici con indice dispari 



  

FUNZIONI TRIGONOMETRICHE



  

Studio di funzioni

Angoli e radianti : l’angolo e’ una parte di piano ottenuta tracciando, a partire da un 
punto, due semirette aventi la stessa origine, Cosi’ facendo si divide il piano in due 
parti dette appunto angoli, caratterizzate quindi da una certa ampiezza

Si definisce una misura dell’angolo usando ad esempio i gradi , un grado e’ definito 
come la 360-esima parte di un angolo giro



  

Studio di funzioni



  

Studio di funzioni

In matematica, le funzioni trigonometriche o funzioni goniometriche o 
funzioni circolari sono funzioni di un angolo



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni



  

Studio di funzioni

Dobbiamo restringere 
l’insieme di definizione  visto
che la funzione tangente è
una funzione suriettiva ma non 
iniettiva  



  

Studio di funzioni
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LIMITI



  

Studio di funzioni

● Il calcolo del limite di certo serve ad esempio a 
studiare il comportamento di una funzione nell’intorno 
di un punto o all’infinito

– l e’ il limite di f(x) per x che tende a x0 se per ogni 
numero reale e>0 esiste un altro numero reale 
positivo d tale che 0 < |x -x0 | < d allora |f(x) - l | < e

– Ovviamente e’ abbastanza immediata l’estensione 
al caso in cui l o x0 siano infiniti 



  

Studio di funzioni



  

Studio di funzioni

● Lo studio del limite serve a studiare il comportamento di 
una funzione nell’intorno di un punto

● Possiamo quindi capire verso quale valore tende la 
funzione man mano che i valori della variabile 
indipendente tendono a quel punto



  

STIMA DEL LIMITE USANDO I 
FOGLI DI CALCOLO



  

Studio di funzioni

● Cercheremo di stimare il valore del limite in un paio di casi

● Iniziamo inserendo in A2 il valore 0.8 e poi in A3 scriviamo 
= A2+0.01

● Mentre in B2 mettiamo il valore della y e quindi 
=(A2^2+A2-2)/(A2-1)

● E poi solito trascinamento fino ad arrivare ad x pari 0.99 



  

Studio di funzioni



  

Studio di funzioni

● Adesso in A23 inseriamo =A22+0.001

● Al solito trasciniamo fino ad A30 e stessa cosa sulla 
colonna B



  

Studio di funzioni

● Adesso approssimiamo il limite destro

● In D2 mettiamo 1.2 ed in D3 =D2-0.01 e trasciniamo fino a 
D21 

● In D22 inseriamo =D21-0.001   e trasciniamo fino a D30

● In E2 invece come prima inseriamo i valori di y e quindi   
=(D2^2+D2-2)/(D2-1)

● Trascinando dovremmo in fine ottenere 



  

Studio di funzioni

   



  

Studio di funzioni

● Questo ci permette di dire che il limite vale 3 con una certa 
incertezza ovvio 

● Di fatto basta ricordarsi che (X2 + X – 2) = (X-1) * (X+2)

infatti:



  

ESERCIZIO



  

Studio di funzioni

● Provate adesso voi



  

Studio di funzioni
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GRAFICO



  

Studio di funzioni

● Il grafico di una funzione è definito come l’insieme di punti 
del piano cartesiano dato da:

● Quindi il luogo geometrico dei punti del piano per cui ogni 
ascissa x appartenente al dominio della funzione si 
associa l’ordinata y 



  

Studio di funzioni

   



  

Studio di funzioni

● Fare il grafico con il foglio di calcolo lo abbiamo in parte 
già visto e’ banale:



  

DERIVATA



  

Derivata

● In matematica, la derivata è la misura di quanto la crescita 
di una funzione cambi al variare del suo argomento. La 
derivata di una funzione è una grandezza puntuale, cioè si 
calcola punto per punto.

● Nel caso di funzioni di nostro interesse funzioni ad una 
variabile nel campo reale e’ la pendenza della tangente al 
grafico della funzione (la migliore approssimazione lineare 
in quel punto)



  

Derivata

  

Derivata: misura la velocità 
di variazione istantanea di 
una funzione. 
Geometricamente, 
rappresenta la pendenza 
della retta tangente al 
grafico della funzione in un 
punto.



  

Derivata



  

INTEGRALE



  

Integrale

  Il Teorema fondamentale del calcolo integrale stabilisce un 
legame preciso tra derivata e integrale. Esso afferma, in 
sostanza, che:

● Se deriviamo una funzione integrale, otteniamo la funzione 
integranda. In altre parole, se prima integriamo una funzione e 
poi deriviamo il risultato, torniamo alla funzione di partenza.

● L'integrale definito di una funzione può essere calcolato 
trovando una primitiva della funzione integranda. Una primitiva 
di una funzione f(x) è una funzione F(x) la cui derivata è 
uguale a f(x



  

Integrale

  Considera la funzione  f(x) = 2x.

● Integrazione: L'integrale indefinito di f(x) è F(x) = x² + C (dove C è 
una costante arbitraria).

● Derivazione: Se deriviamo F(x) = x² + C, otteniamo f(x) = 2x.

È importante notare che l'integrale indefinito non restituisce 
un'unica funzione, ma un insieme di funzioni che differiscono per 
una costante (la famosa "+ C"). Quindi, la relazione tra derivata e 
integrale non è un'inversa perfetta come lo è, ad esempio, tra 
addizione e sottrazione.



  

Integrale

  ● Possiamo dare una definizione banale di integrale definito 
secondo Riemann, come l’operatore matematico che 
associa alla funzioni reali di variabili reali l’area sottesa al 
grafico su un intervallo dato



  

Integrale

  ● Posso stimare ragionevolmente bene un integrale usando 
un foglio di calcolo ?



  

Integrale

  



  

ESEMPIO



  

Derivata

  ● Consideriamo ad esempio la funzione 

f(x) = 2x3 + 6x2 – 12x + 4



  

Derivata

  ● E dunque trascianiamo fino a 102 ottendo:



  

Derivata

  ● Adesso calcoliamo il valore di Y 



  

Derivata

  ● Possiamo dunque graficare 



  

Derivata

  ● Possiamo calcolare la derivata semplicemente usando la 
formula:



  

Derivata

  ● E quindi possiamo plottare funzione e derivata assieme



  

Derivata

  ● Facile fare una verifica usando la derivata analitica 



  

Derivata

  ● Facile fare una verifica usando la derivata analitica 



  

Integrale

  

● Abbiamo detto che calcolare l’integrale definitoi 
corrisponde al calcolo dell’area sottesta sotto la curva

● Trovare l'area usando un metodo di approssimazione noto 
come somme di Riemann. Fondamentalmente stiamo 
disegnando molti di rettangoli che approssimano la forma 
della nostra curva. Se sommiamo l'area di ciascun 
rettangolo, conosciamo (più o meno) l'area sotto la curva. 



  

Integrale 

  ● Possiamo dunque determinare l’area di ogni rettangolo



  

Integrale 

  ● Ed a seguire banalmente la sommatoria delle aree dei 
rettangoli



  

Integrale 

  ● E dunque l’integrale ad esempio 



  

Integrale 

  ● Vediamo ad esempio il calcolo dell’integrale definito



  

TEST



  

Test 

  ● Calcolare la derivata di f(x) = x2 + 2 Punto per punto e 


